WDCP主机管理系统php5.4升级脚本

该升级只是升级PHP的版本,相应的zend,eaccelerator没有升级
且zend opt从php5.3开始已不再支持,也就是说有用到zend opt的,就不要升级了,否则只会瞎折腾

升级方法如下:
下载下面的附件 php_up54.zip,

解压后将sh文件上传到root目录下(或当前工作路径),
然后在SSH里执行此命令 sh php_up54.sh

脚本里的PHP版本为5.4.36,如果以后发布了新版本的话,执行:(将版本号改成实际的版本号即可)

sh php_up54.sh 版本号

 

注意:当出现类似于下面的错误时,可能是由于PHP5.4限制了小于1G内存的主机的安装

make: *** [ext/date/lib/parse_date.lo] Error 1

make er

可以通过以下步骤来解决:

用专门的文本编辑器(如Notepad++、EditPlus等,不要用记事本打开)打开下载好的sh文件,找到–disable-rpath字段(有两处)
都修改为:–disable-fileinfo,这样就可以绕过检测来安装。

下载:php_up54

发表评论

电子邮件地址不会被公开。 必填项已用*标注