ubuntu 10.04使用apt-get安装软件时一直提示E:unable to locate package

因为目前ubuntu 10.04这个版本已经停止更新了,当使用apt-get update命令时,会提示忽略和无法下载404等错误。

下面是Ubuntu 10.04的/etc/apt/source.list文件的原始内容:

deb http://archive.ubuntu.com/ubuntu lucid main restricted universe
deb http://archive.ubuntu.com/ubuntu lucid-updates main restricted universe
deb http://archive.ubuntu.com/ubuntu lucid-security main restricted universe

将Ubuntu 10.04的/etc/apt/source.list文件中archive.ubuntu.com修改为old-releases.ubuntu.com 如下所示:

deb http://old-releases.ubuntu.com/ubuntu lucid main restricted universe
deb http://old-releases.ubuntu.com/ubuntu lucid-updates main restricted universe
deb http://old-releases.ubuntu.com/ubuntu lucid-security main restricted universe

这样,运行apt-get update或apt-get install就可以更新或者安装软件了。

ubuntu 10.04使用apt-get安装软件时一直提示E:unable to locate package》有2个想法

  1. Pingback引用通告: 64M小内存的VPS上搭建lighttpd+PHP+MySQL环境并运行WordPress « 老王笔记

发表评论

电子邮件地址不会被公开。 必填项已用*标注